<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="author" content="Vance Carlson" />
<meta property="news_keywords" content="sports, panthers,boys basketball" />
<meta property="description" content="Failing to close out close games resulted in a 14-game losing streak for the Park Rapids boys basketball team.The Panthers snapped that streak Tuesday night..." />
<meta property="keywords" content="sports, panthers,boys basketball" />
<meta property="article:publisher" content="https://www.facebook.com/editorial.parkrapids" />
<meta property="article:tag" content="sports, panthers,boys basketball" />
<meta property="article:published_time" content="2017-02-18T10:01:00-06:00" />
<meta property="image:alt" content="Park Rapids&#039; Tristin Persons (24) drove in for a layup as East Grand Forks&#039; Aaron Havis went for a block during Tuesday night&#039;s game. Vance Carlson / Enterprise" />
<meta property="article:modified_time" content="2017-02-18T10:01:00-06:00" />
<meta property="twitter:card" content="summary_large_image" />
<meta property="twitter:title" content="Panthers edge EGF, end losing streak" />
<meta property="twitter:image" content="http://www.parkrapidsenterprise.com/sites/default/files/styles/16x9_430/public/0BzGXvxXEqzHuWnNoZ0FFeEw0dFU.jpg?itok=JANnxcck" />
<meta property="twitter:url" content="http://www.parkrapidsenterprise.com/sports/panthers/4219915-panthers-edge-egf-end-losing-streak" />
<meta property="fb:app_id" content="165733053592032" />
<meta property="image:title" content="Park Rapids&#039; Tristin Persons (24) drove in for a layup as East Grand Forks&#039; Aaron Havis went for a block during Tuesday night&#039;s game. Vance Carlson / Enterprise" />
<meta property="twitter:description" content="Failing to close out close games resulted in a 14-game losing streak for the Park Rapids boys basketball team.The Panthers snapped that streak Tuesday night by holding off a late charge by East Grand Forks at the Area High School gym.A 9-2 run in the final 2:25 rallied East Grand Forks to a 58-58 tie..." />
<meta property="og:type" content="article" />
<meta property="og:description" content="Failing to close out close games resulted in a 14-game losing streak for the Park Rapids boys basketball team.The Panthers snapped that streak Tuesday night by holding off a late charge by East Grand Forks at the Area High School gym.A 9-2 run in the final 2:25 rallied East Grand Forks to a 58-58 tie..." />
<meta property="og:url" content="http://www.parkrapidsenterprise.com/sports/panthers/4219915-panthers-edge-egf-end-losing-streak" />
<meta property="og:image:width" content="300" />
<meta property="og:image" content="http://www.parkrapidsenterprise.com/sites/default/files/styles/square_300/public/0BzGXvxXEqzHuWnNoZ0FFeEw0dFU.jpg?itok=R1xEOLTu" />
<meta property="og:image:height" content="300" />
<meta property="og:title" content="Panthers edge EGF, end losing streak" />
<link rel="shortcut icon" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/favicon.ico" type="image/x-icon" />
<link rel="apple-touch-icon" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="amphtml" href="http://www.parkrapidsenterprise.com/sports/panthers/4219915-panthers-edge-egf-end-losing-streak?amp" />
<link rel="shortlink" href="/node/4219915" />
<link rel="canonical" href="/sports/panthers/4219915-panthers-edge-egf-end-losing-streak" />
    <title>Panthers edge EGF, end losing streak | Park Rapids Enterprise</title>
    <link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.2/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/css/article-slider.css?olh0od" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?olh0od" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/css/global-no-mqs.css?olh0od" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/css/global.css?olh0od" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-19', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.2/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?olh0od"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?olh0od"></script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-ParkRapidsEnterprise"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

            if (jQuery(window).width() >= 728) {
              jQuery.getScript('//biddr.brealtime.com/49170050-648.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/49170050-648.js');
              });
            } else {
              jQuery.getScript('//biddr.brealtime.com/91130429-649.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/91130429-649.js');
              });
            }
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="http://a.postrelease.com/serve/load.js?async=true"></script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4219915 node-type-article domain-www-parkrapidsenterprise-com context-sports"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
            <div id='out-of-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('out-of-page-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Park Rapids Enterprise"><img src="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/logo.png" alt="Park Rapids Enterprise" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Park Rapids Enterprise</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/sports/panthers/4219915-panthers-edge-egf-end-losing-streak" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4218580-purple-plungers-jump-ice-cold-good-cause'>Purple Plungers jump for a ice cold good cause</a></li><li><a href='/news/4218714-turn-century-courthouse-needs-repairs'>Turn-of-the-century courthouse needs repairs</a></li><li><a href='/news/4218577-itasca-hosts-old-time-logging-demonstration'>Itasca hosts old-time logging demonstration</a></li><li><a href='/news/4218560-ice-time-ambition-fundraiser-help-disabled-hockey-team-go-nationals'>Ice-time ambition: Fundraiser to help disabled hockey team go to nationals</a></li><li><a href='/news/4218550-hubbard-county-incidents'>Hubbard County Incidents</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/local" target="_self">local</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/state" target="_self">state</a></li><li><a href="/news/records" target="_self">records</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/panthers/4220924-hornets-escape-defeat-panthers-section-final'>Hornets escape, defeat Panthers in section final</a></li><li><a href='/sports/panthers/4219919-warroads-12-0-win-eliminates-panthers'>Warroad&#039;s 12-0 win eliminates Panthers</a></li><li><a href='/sports/tigers/4219918-tigers-end-verndales-winning-streaks'>Tigers end Verndale&#039;s winning streaks</a></li><li><a href='/sports/panthers/4219917-panthers-drop-trio-games'>Panthers drop trio of games</a></li><li><a href='/sports/panthers/4219915-panthers-edge-egf-end-losing-streak'>Panthers edge EGF, end losing streak</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/panthers" target="_self">panthers</a></li><li><a href="/sports/tigers" target="_self">tigers</a></li><li><a href="/sports/braves" target="_self">braves</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4217417-james-harold-hukki'>James Harold Hukki</a></li><li><a href='/obituaries/4219953-mildred-broadbent'>Mildred Broadbent</a></li><li><a href='/obituaries/4219183-kay-loraine-sjolin'>Kay Loraine Sjolin</a></li><li><a href='/obituaries/4219184-abner-jonas'>Abner Jonas</a></li><li><a href='/obituaries/4218052-loree-ann-loretta-cusey'>Loree Ann &quot;Loretta&quot; Cusey</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">business</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/business/4219097-stellar-equine-sports-massage-provides-tension-relief-horses'>Stellar Equine Sports Massage provides tension relief to horses</a></li><li><a href='/business/4214371-building-customer-loyalty'>Building Customer Loyalty
</a></li><li><a href='/business/4214367-dr-keller-named-partner-vision-source'>Dr. Keller named partner at Vision Source</a></li><li><a href='/business/4201397-geriatric-services-extended-tsz'>Geriatric services extended at TSZ</a></li><li><a href='/business/4197600-basic-business-cents-understand-your-organizational-culture'>Basic Business Cents: Understand your organizational culture</a></li></ul></div></div></li><li class='leaf'><a href="/entertainment" target="_self">entertainment</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/entertainment/4220090-nevis-students-artwork-chosen-youth-exhibit'>Nevis students&#039; artwork chosen for youth exhibit </a></li><li><a href='/entertainment/4214365-lifelong-learning-program-focuses-water-quality'>Lifelong Learning program focuses on water quality</a></li><li><a href='/entertainment/4213417-native-pride-arts-dancer-larry-yazzie-returning-park-rapids'>Native Pride Arts Dancer Larry Yazzie returning to Park Rapids</a></li><li><a href='/entertainment/4209299-piece-my-heart-heads-sections'>&#039;A Piece of My Heart&#039; heads to Sections</a></li><li><a href='/entertainment/4209295-menahgas-one-act-play-headed-sections'>Menahga&#039;s One-Act Play headed to Sections</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/entertainment/art" target="_self">art</a></li><li><a href="/entertainment/events" target="_self">events</a></li><li><a href="/entertainment/music" target="_self">music</a></li><li><a href="/entertainment/theater" target="_self">theater</a></li></ul></div></div></li><li class='leaf'><a href="/outdoors" target="_self">outdoors</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/outdoors/4217079-remaining-weeks-ice-fishing-primetime-catching-crappies'>Remaining weeks of ice fishing primetime for catching crappies</a></li><li><a href='/outdoors/4207963-about-fishing-something-smells-fishy'>About Fishing: Something smells fishy </a></li><li><a href='/outdoors/4207016-public-input-sought-border-border-orv-trail'>Public input sought on Border to Border ORV trail</a></li><li><a href='/outdoors/4207015-landowners-asked-allow-walk-access-hunters'>Landowners asked to allow walk-in access to hunters</a></li><li><a href='/outdoors/4207014-public-meetings-will-discuss-deer-management-goals'>Public meetings will discuss deer management goals</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/outdoors/environment" target="_self">environment</a></li><li><a href="/outdoors/fishing" target="_self">fishing</a></li><li><a href="/outdoors/hunting" target="_self">hunting</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/commentary/4218717-commentary-ready-take-pants-charity'>Commentary: Ready to take pants off for charity</a></li><li><a href='/opinion/4218575-letter-united-we-stand-divided-we-fall'>Letter: United we stand; divided we fall</a></li><li><a href='/opinion/4218548-commentary-always-something-panic-about'>Commentary: Always something to panic about</a></li><li><a href='/opinion/4214368-letter-educate-yourself-line-3-pipeline'>Letter: Educate yourself on Line 3 pipeline</a></li><li><a href='/opinion/4214369-letter-many-concerns-proposed-road-vehicle-trail'>Letter: Many concerns with proposed off-road vehicle trail</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/commentary" target="_self">commentary</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="/opinion/letters" target="_self">letters</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/3991482-church-directory'>CHURCH DIRECTORY</a></li><li><a href='/life/food/4113371-recipes-back-school'>Recipes: Back to school</a></li><li><a href='/life/4089575-us-navy-capt-park-rapids-completes-tour-cjtf-hoa'>U.S. Navy Capt. from Park Rapids completes tour in CJTF-HOA</a></li><li><a href='/life/4089574-blueberry-breakfasts'>Blueberry Breakfasts</a></li><li><a href='/life/4084742-recipe-pasta-and-meatballs'>Recipe: Pasta and Meatballs</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/anniversaries" target="_self">anniversaries</a></li><li><a href="/life/births" target="_self">births</a></li><li><a href="/life/engagements" target="_self">engagements</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/weddings" target="_self">weddings</a></li><li><a href="/life/faith" target="_self">faith</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="sports "> <meta itemprop='dateline' content="Park Rapids,Minnesota 56470"> <meta itemprop='articleBody' content="&lt;p&gt;Failing to close out close games resulted in a 14-game losing streak for the Park Rapids boys basketball team.&lt;/p&gt;&lt;p&gt;The Panthers snapped that streak Tuesday night by holding off a late charge by East Grand Forks at the Area High School gym.&lt;/p&gt;&lt;p&gt;A 9-2 run in the final 2:25 rallied East Grand Forks to a 58-58 tie before Payton Hill's free throw with :04 remaining gave the Panthers a 59-58 victory.&lt;/p&gt;&lt;p&gt;&quot;The boys have always been determined to get the next win when we went through the long losing streak,&quot; said Park Rapids head coach Matt Brandt. &quot;We really revamped our offense and added some tweaks to our defense. Since we have made those adjustments, we have been attacking the basket and averaging 15 extra points a game and our shooting percentage has increased and that has been great.&quot;&lt;/p&gt;&lt;p&gt;A jumper by Jason Haas, four inside baskets by Hunter Jewison and a layup by Adam Herberg gave the Panthers a 12-7 lead with 12:22 to play in the first half. Park Rapids would not trail the rest of the game.&lt;/p&gt;&lt;p&gt;Jewison scored off a rebound, Jake Dickinson scored inside, and Haas scored off a steal, hit a jumper and scored on a layup as the Panthers led 22-11 at the 6:36 mark. A layup by Tristin Persons and a basket off a rebound by Jewison made it 27-14 with 1:49 to play in the first half before the Green Wave cut the gap to 29-21 at the break.&lt;/p&gt;&lt;p&gt;Jewison, Gabe Bagstad and Haas combined for 16 points as the Panthers maintained a 48-41 lead with 5:54 to play. A layup by Haas, a jumper by Jewison and layups by Bagstad and Persons made it 56-49 with 2:33 remaining.&lt;/p&gt;&lt;p&gt;A 3-pointer by Christian Dugan, layups by Edmond Jones and Steven Widman, and a jumper by Dugan tied the game at 58-58 with :17 remaining before Hill was fouled on a drive to the basket and hit a free throw for the game-winner.&lt;/p&gt;&lt;p&gt;Jewison finished with a double-double of 22 points and 12 rebounds while Haas added 14 points as the Panthers improved to 3-8 against Section 8AA teams and 4-19 overall. Dickinson chipped in five rebounds and four assists, Bagstad had five rebounds and Persons had three assists as Park Rapids prevailed despite going 0-for-5 on 3-pointers and turning the ball over 18 times.&lt;/p&gt;&lt;p&gt;Dugan (11), Sam Votava (11), Julian Benson (11) and Aaron Havis (10) hit double figures for East Grand Forks, which fell to 3-5 against section opponents and 9-12 overall.&lt;/p&gt;&lt;p&gt;&quot;We knew our defense needed to be tough and we did a nice job. At times we were slow on our rotations, but in the end we got the job done,&quot; said Brandt. &quot;Offensively, we knew we needed to attack the basket and let things develop and they did just that. It is always fun to see us reach the 59-point mark without hitting one 3-pointer. That means the kids were efficient on offense and moved the ball and found the open player.&quot;&lt;/p&gt;&lt;p&gt;EAST GRAND FORKS: Havis 10, Vossler 1, Jones 7, Votava 11, Dugan 11, Widman 3, Benson 11, Stanislawski 2, Dauksavage 2.&lt;/p&gt;&lt;p&gt;PARK RAPIDS: Herberg 1 1-2 3, Haas 7 0-2 14, Dickinson 1 0-0 2, Persons 4 0-0 8, Jewison 11 0-0 22, Bagstad 3 3-5 9, Johnson 0 0-0 0, Hill 0 1-2 1. Totals: 27 for 56 (FG), 5 for 11 (FT).&lt;/p&gt;&lt;p&gt;Halftime: Park Rapids 29, EGF 21. Rebounds: Park Rapids 28 (Jewison 12, Bagstad 5, Dickinson 5, Herberg 4, Haas 1, Persons 1). Assists: Park Rapids 13 (Dickinson 4, Persons 3, Herberg 2, Haas 2, Bagstad 1). Steals: Park Rapids 5 (Bagstad 2, Haas 1, Dickinson 1, Persons 1). Blocked shots: Park Rapids 2 (Johnson 1, Jewison 1). Team fouls: Park Rapids 21. Fouled out: Jewison. Turnovers: Park Rapids 18.&lt;/p&gt;&lt;p class=&quot;subhead&quot;&gt;Barnesville tops Panthers&lt;/p&gt;&lt;p&gt;Charle Aakre scored 23 points and Kellen Hinsz added 15 points in leading Barnesville to a 66-49 Section 8AA win over the Panthers at the Fargo Civic Center on Feb. 11.&lt;/p&gt;&lt;p&gt;Barnesville, which prevailed despite making only 2 of 18 3-pointers, improved to 4-7 against section opponents and 5-13 overall.&lt;/p&gt;&lt;p&gt;Persons led the Panthers with 17 points and five rebounds.&lt;/p&gt;&lt;p&gt;PARK RAPIDS: Herberg 2 0-0 5, Haas 2 1-3 5, Dickinson 2 2-3 6, Persons 6 2-5 17, Jewison 2 0-0 4, Reish 0 2-4 2, Kosel 1 0-0 3, Ballard 0 0-0 0, Renneberg 0 0-0 0, Johnson 1 0-0 2, Pickar 0 0-0 0, Cook 1 0-0 3, Ohm 1 0-1 2, Hill 0 0-0 0. Totals: 18 for 42 (FG), 7 for 16 (FT).&lt;/p&gt;&lt;p&gt;BARNESVILLE: Aakre 23, Hinsz 15, Peterson 7, Roste 6, Zenzen 6, Tonsfeldt 5.&lt;/p&gt;&lt;p&gt;Halftime: Barnesville 35, Park Rapids 25. Three-pointers: Herberg 1, Persons 3, Kosel 1, Cook 1. Rebounds: Park Rapids 19 (Persons 5, Haas 3, Jewison 3, Dickinson 2, Cook 2, Ohm 2, Johnson 1, Pickar 1). Assists: Park Rapids 9 (Herberg 2, Haas 2, Dickinson 2, Johnson 1, Persons 1, Cook 1). Steals: Park Rapids 3 (Dickinson 2, Persons 1). Blocked shots: Park Rapids 2 (Dickinson 1, Jewison 1). Team fouls: Park Rapids 22. Turnovers: Park Rapids 20.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="Panthers edge EGF, end losing streak"> <meta itemprop='author' content="Vance Carlson"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-02-18T10:00:00"> <meta itemprop='dateModified' content="2017-02-18T10:01:00"> <link itemprop='mainEntityOfPage' content="node/4219915"> </span> <span itemprop="image" itemscope itemtype="http://schema.org/ImageObject"> <meta itemprop="url" content="http://www.parkrapidsenterprise.com/sites/default/files/styles/square_300/public/0BzGXvxXEqzHuWnNoZ0FFeEw0dFU.jpg?itok=R1xEOLTu"> <meta itemprop="width" content="2290"> <meta itemprop="height" content="2051"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Vance Carlson"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="Panthers edge EGF, end losing streak "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Park Rapids"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="203 Henrietta Avenue North"> <meta itemprop='postalCode' content="56470"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>Panthers edge EGF, end losing streak</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/vance-carlson'>Vance Carlson</a></span>
  <span class='node-byline-time'> on Feb 18, 2017  at 10:00 a.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-image-wrapper large'><div style='position: relative;'><img class='node-image large' src='http://www.parkrapidsenterprise.com/sites/default/files/styles/16x9_620/public/0BzGXvxXEqzHuWnNoZ0FFeEw0dFU.jpg?itok=6Mb1Ijn9' data-featherlight='http://www.parkrapidsenterprise.com/sites/default/files/styles/full_1000/public/0BzGXvxXEqzHuWnNoZ0FFeEw0dFU.jpg?itok=_KHOx_jE'><img class='image-info' src='/sites/all/themes/fcc_basetheme/images/image-info.png'><span class='image-caption'>Park Rapids&#039; Tristin Persons (24) drove in for a layup as East Grand Forks&#039; Aaron Havis went for a block during Tuesday night&#039;s game. Vance Carlson / Enterprise</span></div></div><style>.page-node div.article-slider ul li {display:block;} img.image-info {float: none; display: none !important;} div span.image-caption {display: inline-block; width: 100%;}</style><div class='node-body'><p>Failing to close out close games resulted in a 14-game losing streak for the Park Rapids boys basketball team.</p></div><div class='node-body'><p>The Panthers snapped that streak Tuesday night by holding off a late charge by East Grand Forks at the Area High School gym.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_ztllnxrvdyzv4mm6fg7wxwl32e' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>A 9-2 run in the final 2:25 rallied East Grand Forks to a 58-58 tie before Payton Hill's free throw with :04 remaining gave the Panthers a 59-58 victory.</p><p>"The boys have always been determined to get the next win when we went through the long losing streak," said Park Rapids head coach Matt Brandt. "We really revamped our offense and added some tweaks to our defense. Since we have made those adjustments, we have been attacking the basket and averaging 15 extra points a game and our shooting percentage has increased and that has been great."</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>A jumper by Jason Haas, four inside baskets by Hunter Jewison and a layup by Adam Herberg gave the Panthers a 12-7 lead with 12:22 to play in the first half. Park Rapids would not trail the rest of the game.</p><p>Jewison scored off a rebound, Jake Dickinson scored inside, and Haas scored off a steal, hit a jumper and scored on a layup as the Panthers led 22-11 at the 6:36 mark. A layup by Tristin Persons and a basket off a rebound by Jewison made it 27-14 with 1:49 to play in the first half before the Green Wave cut the gap to 29-21 at the break.</p><p>Jewison, Gabe Bagstad and Haas combined for 16 points as the Panthers maintained a 48-41 lead with 5:54 to play. A layup by Haas, a jumper by Jewison and layups by Bagstad and Persons made it 56-49 with 2:33 remaining.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>A 3-pointer by Christian Dugan, layups by Edmond Jones and Steven Widman, and a jumper by Dugan tied the game at 58-58 with :17 remaining before Hill was fouled on a drive to the basket and hit a free throw for the game-winner.</p><p>Jewison finished with a double-double of 22 points and 12 rebounds while Haas added 14 points as the Panthers improved to 3-8 against Section 8AA teams and 4-19 overall. Dickinson chipped in five rebounds and four assists, Bagstad had five rebounds and Persons had three assists as Park Rapids prevailed despite going 0-for-5 on 3-pointers and turning the ball over 18 times.</p><p>Dugan (11), Sam Votava (11), Julian Benson (11) and Aaron Havis (10) hit double figures for East Grand Forks, which fell to 3-5 against section opponents and 9-12 overall.</p><p>"We knew our defense needed to be tough and we did a nice job. At times we were slow on our rotations, but in the end we got the job done," said Brandt. "Offensively, we knew we needed to attack the basket and let things develop and they did just that. It is always fun to see us reach the 59-point mark without hitting one 3-pointer. That means the kids were efficient on offense and moved the ball and found the open player."</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>EAST GRAND FORKS: Havis 10, Vossler 1, Jones 7, Votava 11, Dugan 11, Widman 3, Benson 11, Stanislawski 2, Dauksavage 2.</p><p>PARK RAPIDS: Herberg 1 1-2 3, Haas 7 0-2 14, Dickinson 1 0-0 2, Persons 4 0-0 8, Jewison 11 0-0 22, Bagstad 3 3-5 9, Johnson 0 0-0 0, Hill 0 1-2 1. Totals: 27 for 56 (FG), 5 for 11 (FT).</p><p>Halftime: Park Rapids 29, EGF 21. Rebounds: Park Rapids 28 (Jewison 12, Bagstad 5, Dickinson 5, Herberg 4, Haas 1, Persons 1). Assists: Park Rapids 13 (Dickinson 4, Persons 3, Herberg 2, Haas 2, Bagstad 1). Steals: Park Rapids 5 (Bagstad 2, Haas 1, Dickinson 1, Persons 1). Blocked shots: Park Rapids 2 (Johnson 1, Jewison 1). Team fouls: Park Rapids 21. Fouled out: Jewison. Turnovers: Park Rapids 18.</p><p class="subhead">Barnesville tops Panthers</p><p>Charle Aakre scored 23 points and Kellen Hinsz added 15 points in leading Barnesville to a 66-49 Section 8AA win over the Panthers at the Fargo Civic Center on Feb. 11.</p><p>Barnesville, which prevailed despite making only 2 of 18 3-pointers, improved to 4-7 against section opponents and 5-13 overall.</p><p>Persons led the Panthers with 17 points and five rebounds.</p><p>PARK RAPIDS: Herberg 2 0-0 5, Haas 2 1-3 5, Dickinson 2 2-3 6, Persons 6 2-5 17, Jewison 2 0-0 4, Reish 0 2-4 2, Kosel 1 0-0 3, Ballard 0 0-0 0, Renneberg 0 0-0 0, Johnson 1 0-0 2, Pickar 0 0-0 0, Cook 1 0-0 3, Ohm 1 0-1 2, Hill 0 0-0 0. Totals: 18 for 42 (FG), 7 for 16 (FT).</p><p>BARNESVILLE: Aakre 23, Hinsz 15, Peterson 7, Roste 6, Zenzen 6, Tonsfeldt 5.</p><p>Halftime: Barnesville 35, Park Rapids 25. Three-pointers: Herberg 1, Persons 3, Kosel 1, Cook 1. Rebounds: Park Rapids 19 (Persons 5, Haas 3, Jewison 3, Dickinson 2, Cook 2, Ohm 2, Johnson 1, Pickar 1). Assists: Park Rapids 9 (Herberg 2, Haas 2, Dickinson 2, Johnson 1, Persons 1, Cook 1). Steals: Park Rapids 3 (Dickinson 2, Persons 1). Blocked shots: Park Rapids 2 (Dickinson 1, Jewison 1). Team fouls: Park Rapids 22. Turnovers: Park Rapids 20.</p></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.parkrapidsenterprise.com/taxonomy/term/21'>sports</a><a class='topic category' href='http://www.parkrapidsenterprise.com/taxonomy/term/21605'>panthers</a><a class='topic tag' href='http://www.parkrapidsenterprise.com/taxonomy/term/14710'>boys basketball</a></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',21);
  ga('send', 'event', 'article', 'paragraphs', '21');
  ga('send', 'event', 'article', 'length', 'characters',4790);
  ga('send', 'event', 'article', 'age', 'More than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',79232);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',21);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '21');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',4790);
  ga('combinedSites.send', 'event', 'article', 'age', 'More than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',79232);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4114139-todd-david-longazo"><span class="number">1. </span>Todd David Longazo</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4220924-hornets-escape-defeat-panthers-section-final"><span class="number">2. </span>Hornets escape, defeat Panthers in section final</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/news/4218550-hubbard-county-incidents"><span class="number">3. </span>Hubbard County Incidents</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4219919-warroads-12-0-win-eliminates-panthers"><span class="number">4. </span>Warroad&#039;s 12-0 win eliminates Panthers</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/opinion/4218575-letter-united-we-stand-divided-we-fall"><span class="number">5. </span>Letter: United we stand; divided we fall</a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4220924-hornets-escape-defeat-panthers-section-final">Hornets escape, defeat Panthers in section final<span class='latest-date'>11 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/entertainment/4220090-nevis-students-artwork-chosen-youth-exhibit">Nevis students' artwork chosen for youth exhibit <span class='latest-date'>22 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4219919-warroads-12-0-win-eliminates-panthers">Warroad's 12-0 win eliminates Panthers<span class='latest-date'>22 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/sports/tigers/4219918-tigers-end-verndales-winning-streaks">Tigers end Verndale's winning streaks<span class='latest-date'>22 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4219917-panthers-drop-trio-games">Panthers drop trio of games<span class='latest-date'>22 hours ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-fcc-advertising block-wishabi-article block-fcc-advertising-wishabi-article odd block-without-title" id="block-fcc-advertising-wishabi-article">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Wishabi Circular widget on Article -->
          <div id='circularhub_module_6251' class='nocontent'></div>
          <script src='http://api.flyertown.ca/6251/2abb546c0a8af6a5/circularhub_module.js'></script>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget even block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><section class="block block-views block-classified-featured-block block-views-classified-featured-block odd" id="block-views-classified-featured-block">
  <div class="block-inner clearfix">
              <h2 class="block-title">Top Ads</h2>
            
    <div class="content clearfix">
      <div class="view view-classified-featured view-id-classified_featured view-display-id-block view-dom-id-2d7b8882c755b9833b5ba7f18b0e2a35">
    
  
  
      <div class="view-content">
        <div class="views-row views-row-1 views-row-odd views-row-first views-row-last top-ad node node-classified view-mode-top-ads-widget clearfix ">
      <div class="views-field-text-3">
      <p style="text-align:center;">
    <span class="field-content">
    <a href="/classifieds-details/2448074">
      OPEN HOUSE: SUNDAY, 1-4PM 1330 3rd Ave N. Fargo, ND Historic Home For Sale $299,000  Historic 3-story home built in 1913 for sale by owner in North    </a>
    </span>
  </p>
  </div>
  </div>
    </div>
              <span class="class-11px"><a href="/classifieds/featured">View all top ads &raquo;</a></span>
</div>    </div>
  </div>
</section><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-homeshq-widget block-boxes-homeshq-widget odd block-without-title" id="block-boxes-homeshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-homeshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="homes_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget even block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='http://www.forumnewspaper.com/PREnterprise/' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/parkrapidsenterprise" title="">Subscribe to the Paper</a></li>      <li><a href="http://www.newspaperprints.com" title="">Buy Newspaper Prints</a></li>
          </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.facebook.com/editorial.parkrapids" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Park Rapids Enterprise</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Park Rapids Enterprise</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">203 Henrietta Avenue North</div>
      <span class="locality">Park Rapids</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">56470</span>
    </div>

    Call us at <div class="tel">(218) 732-3364</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=parkrapidsenterprise.com&tags=sports, panthers,boys basketball',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?olh0od"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?olh0od"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_fmp1S-5y78PyIlN6garUecXqzFXRTmkF862CNm-d-30.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?olh0od"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?olh0od"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>