<!DOCTYPE html PUBLIC "-//W3C//DTD HTML+RDFa 1.1//EN">
<html lang="en" dir="ltr" version="HTML+RDFa 1.1"
  xmlns:content="http://purl.org/rss/1.0/modules/content/"
  xmlns:dc="http://purl.org/dc/terms/"
  xmlns:foaf="http://xmlns.com/foaf/0.1/"
  xmlns:og="http://ogp.me/ns#"
  xmlns:rdfs="http://www.w3.org/2000/01/rdf-schema#"
  xmlns:sioc="http://rdfs.org/sioc/ns#"
  xmlns:sioct="http://rdfs.org/sioc/types#"
  xmlns:skos="http://www.w3.org/2004/02/skos/core#"
  xmlns:xsd="http://www.w3.org/2001/XMLSchema#">
  <head profile="http://www.w3.org/1999/xhtml/vocab">
    <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<meta property="keywords" content="opinion,park rapids lions, Lions Clubs International" />
<meta property="news_keywords" content="opinion,park rapids lions, Lions Clubs International" />
<meta property="description" content="Lions Clubs International celebrates a century of service this year and has grown to be the largest service organization in the world. Melvin Jones founded..." />
<meta property="author" content="Enterprise Staff" />
<meta property="article:published_time" content="2017-04-21T09:08:48-05:00" />
<meta property="article:modified_time" content="2017-04-21T09:08:48-05:00" />
<meta property="fb:app_id" content="165733053592032" />
<meta property="twitter:url" content="http://www.parkrapidsenterprise.com/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities" />
<meta property="article:publisher" content="https://www.facebook.com/editorial.parkrapids" />
<meta property="article:tag" content="opinion,park rapids lions, Lions Clubs International" />
<meta property="twitter:title" content="ENTERPRISE EDITORIAL: Lions International celebrates 100 years..." />
<meta property="og:url" content="http://www.parkrapidsenterprise.com/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities" />
<meta property="twitter:description" content="Lions Clubs International celebrates a century of service this year and has grown to be the largest service organization in the world. Melvin Jones founded the club on June 7, 1917, and now 100 years later, there are over 45,000 clubs and more than 1.3 million members in 203 countries worldwide.Jones,..." />
<meta property="twitter:image" content="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/images/touch-icon.png" />
<meta property="twitter:card" content="summary" />
<meta property="og:type" content="article" />
<meta property="og:title" content="ENTERPRISE EDITORIAL: Lions International celebrates 100 years..." />
<meta property="og:image" content="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/images/touch-icon.png" />
<meta property="og:description" content="Lions Clubs International celebrates a century of service this year and has grown to be the largest service organization in the world. Melvin Jones founded the club on June 7, 1917, and now 100 years later, there are over 45,000 clubs and more than 1.3 million members in 203 countries worldwide.Jones,..." />
<meta property="og:image:height" content="200" />
<meta property="og:image:width" content="200" />
<script type="text/javascript" src="//s.ntv.io/serve/load.js" async></script><link rel="apple-touch-icon" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/images/touch-icon.png" type="image/png" />
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=2.0, minimum-scale=0.5, user-scalable=yes" />
<link rel="shortcut icon" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/favicon.ico" type="image/x-icon" />
<link rel="amphtml" href="http://www.parkrapidsenterprise.com/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities?amp" />
<script type="application/javascript" src="https://content.jwplatform.com/libraries/R6N0vQlD.js" />
</script><link rel="shortlink" href="/node/4254534" />
<link rel="canonical" href="/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities" />
<meta name="Generator" content="Drupal 7 (http://drupal.org)" />
    <title>ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities | Park Rapids Enterprise</title>
    <link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_rEI_5cK_B9hB4So2yZUtr5weuEV3heuAllCDE6XsIkI.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_s03_ouljUuspf04Mu33L4-w5-jjMVCPB0hfXbp6v04g.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_drAaZvIujzE0WQHPZOt8-T119XbC59ClvGgsZR7SC8M.css" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_n1pCl2MA43tzliKvK4qXdpArepfCRU6u4sc5BywLwKU.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://unpkg.com/leaflet@1.0.2/dist/leaflet.css" media="all" />
<link type="text/css" rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700" media="all" />
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_-4S8c2jcxbs1gWpaJrWx2fB7l84-Ww7NRTVyxDCBH7I.css" media="all" />

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_cJsge75ubbR-lGzepYwLuU3Z8ch1IrsZDx5aSlDs__M.css" media="print" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/css/article-slider.css?ook9l6" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/css/featherlight.min.css?ook9l6" media="all" />
<!--<![endif]-->

<!--[if lte IE 8]>
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/css/global-no-mqs.css?ook9l6" media="all" />
<![endif]-->

<!--[if gt IE 8]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/css/global.css?ook9l6" media="all" />
<!--<![endif]-->

<!--[if (lt IE 9)&(!IEMobile)]>
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_h7dZJ4SGhBPblw5MFhWB5lEUUHZodCULH3O-ZXgVv0M.css" media="all" />
<![endif]-->

<!--[if gte IE 9]><!-->
<link type="text/css" rel="stylesheet" href="http://www.parkrapidsenterprise.com/sites/default/files/css/css_EFG_CH3uZ4YjwsKUY2BjPl69tPfMiB0UKmsKOzpXt5k.css" media="all" />
<!--<![endif]-->
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_i9vAYWtv6IzHqwhy80-mNt0nMbj6ItfIIfYo9XNSP4I.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_9xKWV5CISD-YBXQ1tn5i-yvPXYsen1swMNl0vfhq8nQ.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_NDvHtdToyr9KI_VRhvrkdvoS0h-5mbaC7nYaA4yn4c4.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_tKYV-tUUZkCPmu0K-3gDno2p0xevGnewdyNIVGGcHaw.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
        (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
        m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
        })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

        ga('create', 'UA-778232-19', 'auto')
        ga('create', 'UA-41542537-2', 'fccnn.com', { 'name': 'combinedSites'});
        ga('require', 'linkid', 'linkid.js');
        ga('require', 'displayfeatures');
        ga('combinedSites.require', 'linkid', 'linkid.js');
        ga('combinedSites.require', 'displayfeatures');
        ga('set', 'dimension1', 'anonymous');
        var pixelRatio = (window.devicePixelRatio >= 1.5) ? 'HiDPI' : '1X';
        ga('set', 'dimension2', pixelRatio);
        ga('send', 'pageview');
        ga('combinedSites.send', 'pageview');
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_dw8vp3sZhDu3IiuuDl9okWDOmYLV7szkmH6QKmEisVg.js"></script>
<script type="text/javascript" src="https://unpkg.com/leaflet@1.0.2/dist/leaflet.js"></script>
<script type="text/javascript" src="https://api.fccinteractive.com/gmaps-kml-app/feeds/radar/js/min/radar.min.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_6LNmYXbJFrF_7W14muxt2N3zanu-C3tyGNx5A7k4lQ8.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat_config.min.js?ook9l6"></script>
<script type="text/javascript" src="//static.chartbeat.com/js/chartbeat_mab.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/modules/custom/fcc_advertising/chartbeat/min/chartbeat.min.js?ook9l6"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

       var OX_dfp_options = {prefetch: true};
       if (jQuery(window).width() >= 728) {
         var OX_dfp_ads = [
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x250', '120x600', '160x600', '300x600'], 'article-sidebar-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'top-leaderboard-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['728x90', '320,100', '320,50', '300,50'], 'mid-leaderboard-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['728x90', '980x330', '960x200', '930x180', '970x90', '970x250', '970x66', '980x120'], 'bottom-leaderboard-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x250', '300x600', '160x600', '120x600'], 'first-sidebar-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x250'], 'mid-sidebar-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x250', '300x600', '160x600', '120x600', '240x400', '250x250', '250x360', '300x1050'], 'second-sidebar-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x250', '320x100', '320x50', '300x50'], 'photo-gallery-ad'],
          ];
        } else {
          var OX_dfp_ads = [
            ['/7021/fcc.forum/parkrapidsenterprise', ['300x100', '320x50', '300x50'], 'first-mobile-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['320x100', '320x50', '300x50'], 'second-mobile-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['320x100', '320x50', '300x50'], 'third-mobile-ad'],
            ['/7021/fcc.forum/parkrapidsenterprise', ['320x100', '320x50', '300x50'], 'fourth-mobile-ad'],
          ];
        }

     
//--><!]]>
</script>
<script type="text/javascript" src="//forumcomm-d.openx.net/w/1.0/jstag?nc=7021-ParkRapidsEnterprise"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

      // Load GPT asynchronously
        var googletag = googletag || {};
        googletag.cmd = googletag.cmd || [];
        (function(){
          var gads = document.createElement('script');
          gads.async = true;
          var useSSL = 'https:' == document.location.protocol;
          gads.src = (useSSL ? 'https:' : 'http:') + '//www.googletagservices.com/tag/js/gpt.js';
          var node = document.getElementsByTagName('script')[0];
          node.parentNode.insertBefore(gads, node);
        })();
//--><!]]>
</script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--

            if (jQuery(window).width() >= 728) {
              jQuery.getScript('//biddr.brealtime.com/49170050-648.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/49170050-648.js');
              });
            } else {
              jQuery.getScript('//biddr.brealtime.com/91130429-649.js', function(data, textStatus, jqxhr) {
                console.log('loaded biddr.brealtime.com/91130429-649.js');
              });
            }
//--><!]]>
</script>
<script type="text/javascript" src="//cdn.districtm.ca/merge/all.forumcom.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_CGaraD_dIkCyfGw-2IxWXvZo3VT_wlgYWEqQCaW6yyk.js"></script>
<script type="text/javascript">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</script>
<script type="text/javascript" src="https://cdn.connatix.com/min/connatix.renderer.destination.min.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_Y1rdwRgUs4JbtR_PFE950_FKiFhHKa6FjSWv_MUBj8g.js"></script>
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-56ca182d0de565d1&amp;async=1&amp;domready=1"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_4_LhLQ8kBLbt1AVlytvey9HpNGus6E72kfkXIbmtKRs.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_qpS3kGTqrFq13S5nzMYgDM_AvDfcQ8VncTTWcYuMbyg.js"></script>
<script type="text/javascript">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</script>
    <!--[if lt IE 9]><script src="http://html5shiv.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    <meta http-equiv="X-UA-Compatible" content="IE=edge" /><!-- Google Tag Manager -->
<script type="text/javascript">(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0];var j=d.createElement(s);var dl=l!='dataLayer'?'&l='+l:'';j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;j.type='text/javascript';j.async=true;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PF9F4L');</script>
<!-- End Google Tag Manager -->   </head>
  <body class="html not-front not-logged-in page-node page-node- page-node-4254534 node-type-article domain-www-parkrapidsenterprise-com context-opinion"><!-- Google Tag Manager -->
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-PF9F4L" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<!-- End Google Tag Manager -->
      <div id="skip-link">
          <a href="#main-content" class="element-invisible element-focusable">Skip to main content</a>
      </div>
      <div class="region region-page-top" id="region-page-top">
  <div class="region-inner region-page-top-inner">
      </div>
</div><div class="page clearfix" id="page">
      <header id="section-header" class="section section-header">
    
  <div id="zone-top-leaderboard" class="zone zone-top-leaderboard clearfix container-16">
      </div>
<div id="zone-user-wrapper" class="zone-wrapper zone-user-wrapper clearfix">  
  <div id="zone-user" class="zone zone-user clearfix container-16">
    <div class="grid-5 region region-user-first fcc-omega-user-first first-omega-col" id="region-user-first">
  <div class="region-inner region-user-first-inner">
    <div  class="block block-menu block-menu-login block-menu-menu-login odd" id="block-menu-menu-login">
  <div class="block-inner clearfix">
    <div class="content clearfix">
                    <ul class="menu">
          <li class="first">
            <a href="/user" title="Login">Login</a>
          </li>
          <li class="last">
            <a href="/register" title="Register">Register</a>
          </li>
        </ul>
                </div>
  </div>
</div>  </div>
</div><div class="grid-11 region region-user-second last-omega-col" id="region-user-second">
  <div class="region-inner region-user-second-inner">
    <div class="mobile-button-hq">Classifieds</div>
<div  class="block block-menu block-menu-hq-links block-menu-menu-hq-links odd" id="block-menu-menu-hq-links">
  <div class="block-inner clearfix">
    <div class="content clearfix">
      <ul class="menu"><li class="first leaf"><a href="http://www.carshq.com" title="CarsHQ">CarsHQ</a></li>
<li class="leaf"><a href="http://www.jobshq.com" title="JobsHQ">JobsHQ</a></li>
<li class="leaf"><a href="http://www.homeshq.com" title="HomesHQ">HomesHQ</a></li>
<li class="leaf"><a href="http://www.apartmentshq.com" title="ApartmentsHQ">ApartmentsHQ</a></li>
<li class="leaf"><a href="/classifieds" title="Classifieds">Classifieds</a></li>
<li class="last leaf"><a href="/marketplace_offers" title="Marketplace">Marketplace</a></li>
</ul>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-branding-wrapper" class="zone-wrapper zone-branding-wrapper clearfix">  
  <div id="zone-branding" class="zone zone-branding clearfix container-16">
    <div class="grid-4 region region-branding fcc-omega-brand first-omega-col" id="region-branding">
  <div class="region-inner region-branding-inner">
        <div class="branding-data clearfix">
            <div class="logo-img">
        <a href="/" rel="home" title="Park Rapids Enterprise"><img src="http://www.parkrapidsenterprise.com/sites/all/themes/parkrapidsenterprise_theme/logo.png" alt="Park Rapids Enterprise" id="logo" /></a>      </div>
                        <div class="site-name-slogan">        
                                <h2 class="site-name element-invisible"><a href="/" title="Home">Park Rapids Enterprise</a></h2>
                              </div>
          </div>
          </div>
</div><div class="grid-6 region region-masthead-first" id="region-masthead-first">
  <div class="region-inner region-masthead-first-inner">
    <div class="block block-search block-form block-search-form odd block-without-title" id="block-search-form">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <form action="/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities" method="post" id="search-block-form" accept-charset="UTF-8"><div>  <div class="container-inline">
    <div class="form-item form-type-textfield form-item-search-block-form">
  <label class="element-invisible" for="edit-search-block-form--2">Search </label>
 <input title="Enter the terms you wish to search for." type="text" id="edit-search-block-form--2" name="search_block_form" value="" size="15" maxlength="128" class="form-text" />
</div>
<div class="form-actions form-wrapper" id="edit-actions"><input type="submit" id="edit-submit" name="op" value="Search" class="form-submit" /></div><input type="hidden" name="form_id" value="search_block_form" />
  </div>
</div></form>    </div>
  </div>
</div>  </div>
</div><div class="grid-6 region region-masthead-second fcc-omega-masthead-second last-omega-col" id="region-masthead-second">
  <div class="region-inner region-masthead-second-inner">
    <div class="block block-fcc-weather block-fcc-weather-masthead-wrapper block-fcc-weather-fcc-weather-masthead-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-masthead-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='fcc_weather_masthead_wrapper'></div>    </div>
  </div>
</div><div class="block block-fcc-advertising block-weather-sponsorship block-fcc-advertising-weather-sponsorship even block-without-title" id="block-fcc-advertising-weather-sponsorship">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='weather-sponsorship'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('weather-sponsorship');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div><div id="zone-menu-wrapper" class="zone-wrapper zone-menu-wrapper clearfix fcc-menu-wrapper">  
  <div id="zone-menu" class="zone zone-menu clearfix container-16">
    <div class="grid-16 region region-menu" id="region-menu">
  <div class="region-inner region-menu-inner">
        <div class="block block-fcc-custom-blocks block-doormat-menu block-fcc-custom-blocks-doormat-menu odd block-without-title" id="block-fcc-custom-blocks-doormat-menu">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="mobile-overlay"></div>
<div class="mobile-button-search">Search</div>
<div class="mobile-button-sections">Sections</div>

<div id="zone-menu-anchor"></div>

<div class="block-main-menu">
    <div class="block-inner clearfix">
        <ul class="menu">
            <li class='first leaf'><a href='/'>Home</a></li><li class='leaf logo'><a href='/'><img src='/sites/all/themes/parkrapidsenterprise_theme/logo.png' /></a></li><li class='leaf'><a href="/news" target="_self">news</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/news/4254581-minn-senate-votes-limit-local-power-minimum-wage-related-issues'>Minn. Senate votes to limit local power on minimum wage, related issues</a></li><li><a href='/news/4253384-hubbard-county-law-enforcement-incidents'>Hubbard County Law Enforcement Incidents</a></li><li><a href='/news/4253374-easter-egg-rush-hundreds-gather-eggs-annual-event-nevis'>EASTER EGG RUSH: Hundreds gather eggs at annual event in Nevis</a></li><li><a href='/news/4253372-league-leads-way-protect-natural-resources'>League leads way to protect natural resources</a></li><li><a href='/news/4251865-menahga-school-board-addresses-hearsay-about-giant-bull'>Menahga School Board addresses hearsay about giant bull </a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/news/education" target="_self">education</a></li><li><a href="/news/local" target="_self">local</a></li><li><a href="/news/region" target="_self">region</a></li><li><a href="/news/state" target="_self">state</a></li><li><a href="/news/records" target="_self">records</a></li></ul></div></div></li><li class='leaf'><a href="/sports" target="_self">sports</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/sports/panthers/4254518-jerger-strikes-out-15-panthers-defeat-frazee'>Jerger strikes out 15, Panthers defeat Frazee</a></li><li><a href='/sports/panthers/4252584-panthers-seeking-berth-8aa-meet'>Panthers seeking berth in 8AA meet</a></li><li><a href='/sports/panthers/4252583-bemidji-defeats-panthers-dual'>Bemidji defeats Panthers in dual</a></li><li><a href='/sports/tigers/4252582-tigers-delivered-historic-season'>Tigers delivered historic season</a></li><li><a href='/sports/panthers/4252581-panthers-prepared-reach-potential'>Panthers prepared to reach potential</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/sports/panthers" target="_self">panthers</a></li><li><a href="/sports/tigers" target="_self">tigers</a></li><li><a href="/sports/braves" target="_self">braves</a></li></ul></div></div></li><li class='leaf'><a href="/obituaries" target="_self">obituaries</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/obituaries/4254110-harvey-w-henrikson'>Harvey W. Henrikson</a></li><li><a href='/obituaries/4254545-howard-verne-schulz'>Howard Verne Schulz</a></li><li><a href='/obituaries/4254225-mary-oellien'>Mary A. Oellien</a></li><li><a href='/obituaries/4253939-derald-sterling-johnson'>Derald Sterling Johnson</a></li><li><a href='/obituaries/4252638-james-edward-fox'>James Edward Fox</a></li></ul></div></div></li><li class='leaf'><a href="/business" target="_self">business</a><div class='doormat-menu'><div class='doormat-headlines no-doormat-subcat'><h2>Headlines</h2><ul><li><a href='/business/4246033-business-main-street-meats-wins-grand-championship-awards'>Business: Main Street Meats wins grand championship awards</a></li><li><a href='/business/4246018-basic-business-cents-optimizing-inventory'>Basic Business Cents: Optimizing inventory </a></li><li><a href='/business/4227024-lm-fleet-supply-earns-top-dealer-honor-cub-cadet'>L&amp;M Fleet Supply earns top dealer honor from Cub Cadet </a></li><li><a href='/business/4227016-tm-express-completes-remodel-park-rapids-location'>T&amp;M Express completes remodel at Park Rapids location</a></li><li><a href='/business/4219097-stellar-equine-sports-massage-provides-tension-relief-horses'>Stellar Equine Sports Massage provides tension relief to horses</a></li></ul></div></div></li><li class='leaf'><a href="/entertainment" target="_self">entertainment</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/entertainment/4249023-just-kix-captures-first-place-awards'>Just for Kix captures first place awards</a></li><li><a href='/entertainment/4245671-park-rapids-speech-team-success'>Park Rapids speech team success</a></li><li><a href='/entertainment/4244137-library-hosting-growing-girls-symposium'>Library hosting &#039;Growing Up Girls&#039; symposium</a></li><li><a href='/entertainment/4242510-three-park-rapids-students-headed-state-art-exhibition'>Three Park Rapids students headed to State Art Exhibition</a></li><li><a href='/entertainment/4242504-historian-share-details-itasca-parks-first-white-settlers'>Historian to share details of Itasca Park&#039;s first white settlers</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/entertainment/art" target="_self">art</a></li><li><a href="/entertainment/events" target="_self">events</a></li><li><a href="/entertainment/music" target="_self">music</a></li><li><a href="/entertainment/theater" target="_self">theater</a></li></ul></div></div></li><li class='leaf'><a href="/outdoors" target="_self">outdoors</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/outdoors/4252639-about-fishing-time-sow-and-time-harvest-spring-crappie'>About Fishing: Time to sow and time to harvest with spring crappie</a></li><li><a href='/outdoors/4244601-about-fishing-picking-fish-finder'>About Fishing: Picking a fish finder</a></li><li><a href='/outdoors/4237180-about-fishing-ais-prevention-2017-challenges-facing-hubbard-county'>About Fishing: AIS Prevention 2017 Challenges Facing Hubbard County</a></li><li><a href='/outdoors/4226378-about-fishing-career-charter-fishermen-share-opinions-minnesota-fishing'>About Fishing: Career charter fishermen share opinions on Minnesota fishing
</a></li><li><a href='/outdoors/4217079-remaining-weeks-ice-fishing-primetime-catching-crappies'>Remaining weeks of ice fishing primetime for catching crappies</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/outdoors/environment" target="_self">environment</a></li><li><a href="/outdoors/fishing" target="_self">fishing</a></li><li><a href="/outdoors/hunting" target="_self">hunting</a></li></ul></div></div></li><li class='leaf'><a href="/opinion" target="_self">opinion</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities'>ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities</a></li><li><a href='/opinion/4251863-letter-support-legislation-dealing-protesters'>Letter: Support legislation dealing with protesters</a></li><li><a href='/opinion/4251862-letter-commissioners-should-present-insurance-plan-publicly'>Letter: Commissioners should present insurance plan publicly</a></li><li><a href='/opinion/4251796-letter-airstrikes-masterful-move'>Letter: Airstrikes a masterful move</a></li><li><a href='/opinion/4249610-letter-do-we-really-care-who-gets-most-legitimate-votes'>Letter: Do we really care who gets the most legitimate votes?</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/opinion/commentary" target="_self">commentary</a></li><li><a href="/opinion/editorials" target="_self">editorials</a></li><li><a href="/opinion/letters" target="_self">letters</a></li></ul></div></div></li><li class='leaf'><a href="/life" target="_self">life</a><div class='doormat-menu'><div class='doormat-headlines'><h2>Headlines</h2><ul><li><a href='/life/3991482-church-directory'>CHURCH DIRECTORY</a></li><li><a href='/life/food/4113371-recipes-back-school'>Recipes: Back to school</a></li><li><a href='/life/4089575-us-navy-capt-park-rapids-completes-tour-cjtf-hoa'>U.S. Navy Capt. from Park Rapids completes tour in CJTF-HOA</a></li><li><a href='/life/4089574-blueberry-breakfasts'>Blueberry Breakfasts</a></li><li><a href='/life/4084742-recipe-pasta-and-meatballs'>Recipe: Pasta and Meatballs</a></li></ul></div><div class='doormat-subcats'><h2>More Topics</h2><ul><li><a href="/life/anniversaries" target="_self">anniversaries</a></li><li><a href="/life/births" target="_self">births</a></li><li><a href="/life/engagements" target="_self">engagements</a></li><li><a href="/life/food" target="_self">food</a></li><li><a href="/life/weddings" target="_self">weddings</a></li><li><a href="/life/faith" target="_self">faith</a></li></ul></div></div></li>        </ul>
    </div>
</div>    </div>
  </div>
</div>  </div>
</div>
  </div>
</div>  
  <div id="zone-weather" class="zone zone-weather clearfix container-16">
    <div class="grid-16 region region-weather" id="region-weather">
  <div class="region-inner region-weather-inner">
    <div class="block block-fcc-weather block-fcc-weather-wrapper block-fcc-weather-fcc-weather-wrapper odd block-without-title" id="block-fcc-weather-fcc-weather-wrapper">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div id="fcc_weather_wrapper" class="weather-forecast-container clearfix">
  <h2 class="hide-title">Weather Forecast</h2>
  <a href="javascript:void(0)" id="fcc_weather_close" class="fcc-weather-close">Close</a>
  <div class="weather-col-first">
    <ul class="quicktabs-tabs">
      <li class="first" id="fcc_weather_show_forecast_tab"><a href="javascript:void(0)" id="fcc_weather_show_forecast">Forecast</a></li>
      <li class="last" id="fcc_weather_show_radar_tab"><a href="javascript:void(0)" id="fcc_weather_show_radar">Radar</a></li>
    </ul>
  </div>

  <div class="weather-col weather-col-ad">
    <div class="weather-ad-wrapper">
          </div>
  </div>
</div>
    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-sliding-billboard" class="zone zone-sliding-billboard clearfix container-16">
    <div class="grid-16 region region-sliding-billboard" id="region-sliding-billboard">
  <div class="region-inner region-sliding-billboard-inner">
    <div class="block block-fcc-advertising block-top-leaderboard-ad block-fcc-advertising-top-leaderboard-ad odd block-without-title" id="block-fcc-advertising-top-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='top-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('top-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</header>    
          <section id="section-content" class="section section-content">
    
  <div id="zone-alert" class="zone zone-alert clearfix container-16">
    <div class="grid-16 region region-alert" id="region-alert">
  <div class="region-inner region-alert-inner">
    <div class="block block-fcc-live-video block-fcc-live-video-ajax-container block-fcc-live-video-fcc-live-video-ajax-container odd block-without-title" id="block-fcc-live-video-fcc-live-video-ajax-container">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="fcc-live-video-ajax-container"></div>    </div>
  </div>
</div>  </div>
</div>  </div>
  
  <div id="zone-main-content" class="zone zone-main-content clearfix container-16">
    <div class="grid-10 region region-content fcc-omega-content first-omega-col" id="region-content">
  <div class="region-inner region-content-inner">
    <a id="main-content"></a>
                                                        <ul class="action-links"></ul>    <div class="block block-system block-main block-system-main odd block-without-title" id="block-system-main">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <!-- Schema.org Tags --> <div itemscope itemtype='http://schema.org/NewsArticle'> <meta itemprop='articleSection' content="opinion "> <meta itemprop='dateline' content="Park Rapids,Minnesota 56470"> <meta itemprop='articleBody' content="&lt;p&gt;Lions Clubs International celebrates a century of service this year and has grown to be the largest service organization in the world. Melvin Jones founded the club on June 7, 1917, and now 100 years later, there are over 45,000 clubs and more than 1.3 million members in 203 countries worldwide.&lt;/p&gt;&lt;p&gt;Jones, a Chicago businessman, asked, with regards to his colleagues, &quot;What if these men who are successful because of their drive, intelligence and ambition, were to put their talents to work improving their communities?&quot;&lt;/p&gt;&lt;p&gt;Lions clubs across the world operate under the motto: &quot;We Serve.&quot;&lt;/p&gt;&lt;p&gt;In 1925, Helen Keller beseeched Lions to become &quot;Knights of the Blind&quot; and her eloquent plea provided Lions with their primary mission. The Lions started the Leader Dogs for the Blind in 1939. Women were invited to become members in 1987.&lt;/p&gt;&lt;p&gt;From focusing on vision, Lions Clubs International now addresses, diabetes, hearing and service dogs. In 1968, Lions Clubs International Foundation was established and this addresses the needs of people around the globe who are impacted by disasters such as floods, earthquakes, tornados, wildfires, etc.&lt;/p&gt;&lt;p&gt;The Park Rapids Lions Club received its charter on June 23, 1954, at a meeting held at the Park Rapids Municipal building. Sponsored by the Wadena Lions, the club was chartered with 20 members and elected Robert Brown as their first president.&lt;/p&gt;&lt;p&gt;For 63 years, the Park Rapids Lions continue to serve the community and join this year in celebrating the international club's 100th birthday. The Park Rapids club currently has 47 members and since 1954 has provided volunteer services and financial assistance to those in need throughout the Park Rapids area.&lt;/p&gt;&lt;p&gt;The Leader Dogs for the Blind is one of the major programs to receive club support. Since 2007, the club has contributed about $10,000 to this program.&lt;/p&gt;&lt;p&gt;While the focus internationally is on sight related projects, locally the club contributes to projects such as spring leaf and lawn litter pickup and disposal, scholarships for local high school seniors, Headwaters 100 Bike Ride, financial and volunteer support for Kinship, Food Angels Backpack Program, fountain and tree planting at Depot Park, Hubbard County Food Shelf, piano project, eyeglass purchases for people unable to pay, specialized tricycle for local youth, hearing aids for local youth, ditch pick up, Salvation Army bell ringers, pre-Memorial Day cleanup at Greenwood Cemetery, and many more.&lt;/p&gt;&lt;p&gt;The longest lived community project sponsored by the Lions is the annual spring leaf and lawn litter pick-up on Community Service Day. This project began in the spring of 1974.&lt;/p&gt;&lt;p&gt;To help support the many projects one of the club's major fundraisers is the Park Rapids Lions Garage Sale, this year on Saturday, June 3, from 9 a.m. to 4 p.m.&lt;/p&gt;&lt;p&gt;Local vision related projects include vision assist reading machines for persons with eyesight issues and used eyeglass collection boxes at local businesses. Local Lions members also build wheelchair accessible ramps for local residents.&lt;/p&gt;&lt;p&gt;The Park Rapids Lions over the past 30 years have made financial contributions to many community facilities, recreation and betterment projects and community activities. They contribute with dollars spread out around the area, as well as provide manpower to numerous community events each year. They support programs to benefit youth in the area and help support school programs.&lt;/p&gt;&lt;p&gt;Fifteen local Lions in Park Rapids have received the distinguished Melvin Jones Award for outstanding dedication and service in the Lions organization.&lt;/p&gt;"> <span itemprop='headline'> <meta itemprop='headline' content="ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities"> <meta itemprop='author' content="Enterprise Staff"> <div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"> <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"> <meta itemprop="url" content="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/images/social_default_image.png"> <meta itemprop="width" content="128"> <meta itemprop="height" content="128"> </div> <meta itemprop="name" content="Forum Communications Company"> </div> <meta itemprop='datePublished' content="2017-04-21T09:08:48"> <meta itemprop='dateModified' content="2017-04-21T09:08:48"> <link itemprop='mainEntityOfPage' content="node/4254534"> </span> <div itemscope itemtype='http://schema.org/CreativeWork' id='schemaorg-creative-work'> <meta itemprop='author' content="Enterprise Staff"> </div> <div itemscope itemtype='http://schema.org/Thing' id='schemaorg-name'> <meta itemprop='name' content="ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities "> </div> <div itemscope itemtype='http://schema.org/PostalAddress' id='schemaorg-address'> <meta itemprop='addressLocality' content="Park Rapids"> <meta itemprop='addressRegion' content="Minnesota"> <meta itemprop='streetAddress' content="203 Henrietta Avenue North"> <meta itemprop='postalCode' content="56470"> </div> </div><div id='first-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('first-mobile-ad');
          });
        </script>
        </div><h1 class='node-title'>ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities</h1>
<div class='node-byline'>
  <span class='node-byline-author'>By <a href='/users/enterprise-staff'>Enterprise Staff</a></span>
  <span class='node-byline-time'> on Apr 21, 2017  at 9:08 a.m.</span>
  <!--Share buttons-->
  <div id="sticky-anchor"></div>
  <div id="sticky" class='node-share-buttons'>
    <div class="addthis_sharing_toolbox"></div>
  </div>
  </div><div class='node-body'><p>Lions Clubs International celebrates a century of service this year and has grown to be the largest service organization in the world. Melvin Jones founded the club on June 7, 1917, and now 100 years later, there are over 45,000 clubs and more than 1.3 million members in 203 countries worldwide.</p></div><div id='second-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('second-mobile-ad');
          });
        </script>
        </div>    <script type="text/javascript">
        // Google Consumer Survey
        (function () {
            var ARTICLE_URL = window.location.href;
            var CONTENT_ID = 'everything';
            document.write(
                    '<scr' + 'ipt ' +
                    'src="//survey.g.doubleclick.net/survey?site=_ztllnxrvdyzv4mm6fg7wxwl32e' +
                    '&url=' + encodeURIComponent(ARTICLE_URL) +
                    (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
                    '&random=' + (new Date).getTime() +
                    '" type="text/javascript">' + '\x3C/scr' + 'ipt>');
        })();
    </script>
<div class='p402_premium'><div class='node-body'><p>Jones, a Chicago businessman, asked, with regards to his colleagues, "What if these men who are successful because of their drive, intelligence and ambition, were to put their talents to work improving their communities?"</p><p>Lions clubs across the world operate under the motto: "We Serve."</p><p>In 1925, Helen Keller beseeched Lions to become "Knights of the Blind" and her eloquent plea provided Lions with their primary mission. The Lions started the Leader Dogs for the Blind in 1939. Women were invited to become members in 1987.</p><div id='jobsHQ-hotjobs-single-0' class='jobsHQ-hotjobs-single'></div><p>From focusing on vision, Lions Clubs International now addresses, diabetes, hearing and service dogs. In 1968, Lions Clubs International Foundation was established and this addresses the needs of people around the globe who are impacted by disasters such as floods, earthquakes, tornados, wildfires, etc.</p><p>The Park Rapids Lions Club received its charter on June 23, 1954, at a meeting held at the Park Rapids Municipal building. Sponsored by the Wadena Lions, the club was chartered with 20 members and elected Robert Brown as their first president.</p><p>For 63 years, the Park Rapids Lions continue to serve the community and join this year in celebrating the international club's 100th birthday. The Park Rapids club currently has 47 members and since 1954 has provided volunteer services and financial assistance to those in need throughout the Park Rapids area.</p><div id='jobsHQ-hotjobs-single-1' class='jobsHQ-hotjobs-single'></div><p>The Leader Dogs for the Blind is one of the major programs to receive club support. Since 2007, the club has contributed about $10,000 to this program.</p><p>While the focus internationally is on sight related projects, locally the club contributes to projects such as spring leaf and lawn litter pickup and disposal, scholarships for local high school seniors, Headwaters 100 Bike Ride, financial and volunteer support for Kinship, Food Angels Backpack Program, fountain and tree planting at Depot Park, Hubbard County Food Shelf, piano project, eyeglass purchases for people unable to pay, specialized tricycle for local youth, hearing aids for local youth, ditch pick up, Salvation Army bell ringers, pre-Memorial Day cleanup at Greenwood Cemetery, and many more.</p><div id='jobsHQ-hotjobs-single-2' class='jobsHQ-hotjobs-single'></div><p>The longest lived community project sponsored by the Lions is the annual spring leaf and lawn litter pick-up on Community Service Day. This project began in the spring of 1974.</p><p>To help support the many projects one of the club's major fundraisers is the Park Rapids Lions Garage Sale, this year on Saturday, June 3, from 9 a.m. to 4 p.m.</p><p>Local vision related projects include vision assist reading machines for persons with eyesight issues and used eyeglass collection boxes at local businesses. Local Lions members also build wheelchair accessible ramps for local residents.</p><p>The Park Rapids Lions over the past 30 years have made financial contributions to many community facilities, recreation and betterment projects and community activities. They contribute with dollars spread out around the area, as well as provide manpower to numerous community events each year. They support programs to benefit youth in the area and help support school programs.</p><p>Fifteen local Lions in Park Rapids have received the distinguished Melvin Jones Award for outstanding dedication and service in the Lions organization.</p></div><div style='clear:both;'></div></div><script type="text/javascript">try {_402_Show();} catch (e) {}</script>
<div class='recommended node-ad-mobile nocontent'></div><script type='text/javascript'>
				jQuery('.recommended.node-ad-mobile a').on('click', function() {
					ga('send', 'event', 'Recommended', 'click', 'recommended-click');
					ga('combinedSites.send', 'event', 'Recommended', 'click', 'recommended-click');
				});
			</script><script type='text/javascript'>
    jQuery('.recommended.node-ad-mobile a.with-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click with img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click with img', 'recommended-click');
    });

    jQuery('.recommended.node-ad-mobile a.without-img').on('click', function() {
      ga('send', 'event', 'Recommended', 'click without img', 'recommended-click');
      ga('combinedSites.send', 'event', 'Recommended', 'click without img', 'recommended-click');
    });
  </script><div id='third-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('third-mobile-ad');
          });
        </script>
        </div><div class='node-related-topics clearfix'><span class='label'>Explore related topics:</span><a class='topic category' href='http://www.parkrapidsenterprise.com/taxonomy/term/9'>opinion</a><a class='topic tag' href='http://www.parkrapidsenterprise.com/taxonomy/term/233127'>park rapids lions</a><a class='topic tag' href='http://www.parkrapidsenterprise.com/taxonomy/term/170981'>Lions Clubs International</a></div><div id='ad-content-distribution'></div><div class='node-ad node-ad-mobile'>Advertisement<div id='marketplaceDeal_widget_mobile'></div></div><div id='fourth-mobile-ad' class='mobile-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('fourth-mobile-ad');
          });
        </script>
        </div><script type='text/javascript'>
  ga('send', 'event', 'article', 'length', 'paragraphs',14);
  ga('send', 'event', 'article', 'paragraphs', '14');
  ga('send', 'event', 'article', 'length', 'characters',3637);
  ga('send', 'event', 'article', 'age', 'More than 12 hours');
  ga('send', 'event', 'article', 'age', 'interval',84564);

  // Combined Sites
  ga('combinedSites.send', 'event', 'article', 'length', 'paragraphs',14);
  ga('combinedSites.send', 'event', 'article', 'paragraphs', '14');
  ga('combinedSites.send', 'event', 'article', 'length', 'characters',3637);
  ga('combinedSites.send', 'event', 'article', 'age', 'More than 12 hours');
  ga('combinedSites.send', 'event', 'article', 'age', 'interval',84564);
</script>    </div>
  </div>
</div>          </div>
</div>
<aside class="grid-6 region region-sidebar-first  fcc-omega-sidebar last-omega-col" id="region-sidebar-first">
  <div class="region-inner region-sidebar-first-inner">
    <div class="block block-fcc-advertising block-first-sidebar-ad block-fcc-advertising-first-sidebar-ad odd block-without-title" id="block-fcc-advertising-first-sidebar-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class='node-ad node-ad-desktop'><div id='marketplaceDeal_widget' class='nocontent'></div></div>    </div>
  </div>
</div><div class="block block-fcc-custom-blocks block-trending-latest block-fcc-custom-blocks-trending-latest even block-without-title" id="block-fcc-custom-blocks-trending-latest">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div class="space-eater latest-trending nocontent">
      <div class="select-homepage">
      <a class="active trending" href="/trending">Trending</a>
    </div>
    <div class="space-eater-section fcc-trending">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/region/3857330-death-3-year-old-becker-county-boy-under-investigation"><span class="number">1. </span>Death of 3-year-old Becker County boy under investigation</a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/news/4253384-hubbard-county-law-enforcement-incidents"><span class="number">2. </span>Hubbard County Law Enforcement Incidents</a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4252604-randy-lee-harvala"><span class="number">3. </span>Randy Lee Harvala</a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/obituaries/4254545-howard-verne-schulz"><span class="number">4. </span>Howard Verne Schulz</a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4251865-menahga-school-board-addresses-hearsay-about-giant-bull"><span class="number">5. </span>Menahga School Board addresses hearsay about giant bull </a></div>
      </div>
        <a class="more" href="/trending">more <span class="arrow">〉</span></a>
</div>
    <div class="select-homepage">
    <a class="active latest" href="/latest">Latest</a>
  </div>
  <div class="space-eater-section fcc-latest">
            <div class="space-eater-article space-eater-article-0">
        <div class="space-eater-headline class-14px"><a href="/news/4254581-minn-senate-votes-limit-local-power-minimum-wage-related-issues">Minn. Senate votes to limit local power on minimum wage, related issues<span class='latest-date'>21 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-1">
        <div class="space-eater-headline class-14px"><a href="/opinion/4254534-enterprise-editorial-lions-international-celebrates-100-years-serving-communities">ENTERPRISE EDITORIAL: Lions International celebrates 100 years serving communities<span class='latest-date'>23 hours ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-2">
        <div class="space-eater-headline class-14px"><a href="/sports/panthers/4254518-jerger-strikes-out-15-panthers-defeat-frazee">Jerger strikes out 15, Panthers defeat Frazee<span class='latest-date'>1 day ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-3">
        <div class="space-eater-headline class-14px"><a href="/news/4253384-hubbard-county-law-enforcement-incidents">Hubbard County Law Enforcement Incidents<span class='latest-date'>2 days ago</span></a></div>
      </div>
          <div class="space-eater-article space-eater-article-4">
        <div class="space-eater-headline class-14px"><a href="/news/4253374-easter-egg-rush-hundreds-gather-eggs-annual-event-nevis">EASTER EGG RUSH: Hundreds gather eggs at annual event in Nevis<span class='latest-date'>2 days ago</span></a></div>
      </div>
        <a class="more" href="/latest">more <span class="arrow">〉</span></a>
</div></div>
    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-jobshq-widget block-boxes-jobshq-widget odd block-without-title" id="block-boxes-jobshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-jobshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="jobs_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-carshq-widget block-boxes-carshq-widget even block-without-title" id="block-boxes-carshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-carshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="carsHQ_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div><div class="block block-boxes block-boxes-simple block-apartmentshq-widget block-boxes-apartmentshq-widget odd block-without-title" id="block-boxes-apartmentshq-widget">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='boxes-box-apartmentshq_widget' class='boxes-box'><div class="boxes-box-content"><div id="apartments_widget" class="nocontent"></div>
</div></div>    </div>
  </div>
</div>  </div>
</aside>  </div>
  
  <div id="zone-bottom-leaderboard" class="zone zone-bottom-leaderboard clearfix container-16">
    <div class="grid-16 region region-bottom-leaderboard" id="region-bottom-leaderboard">
  <div class="region-inner region-bottom-leaderboard-inner">
    <div class="block block-fcc-advertising block-bottom-leaderboard-ad block-fcc-advertising-bottom-leaderboard-ad odd block-without-title" id="block-fcc-advertising-bottom-leaderboard-ad">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      <div id='bottom-leaderboard-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('bottom-leaderboard-ad');
          });
        </script>
        </div>    </div>
  </div>
</div>  </div>
</div>  </div>
</section>    
  
      <footer id="section-footer" class="section section-footer">
  <div id="zone-postscript-wrapper" class="zone-wrapper zone-postscript-wrapper clearfix">  
  <div id="zone-postscript" class="zone zone-postscript clearfix container-16">
    <div class="grid-4 fcc-omega-postscript first-omega-col region region-postscript-first">
  <section class="block">
    <h2>Account</h2>
    <ul>
      <li><a href="/user" title="">Manage My Account</a></li>
      <li><a href='http://www.forumnewspaper.com/PREnterprise/' title=''>Manage Home Delivery</a></li>      <li><a href="/privacy" title="">Privacy Policy</a></li>
      <li><a href="/terms" title="">Terms and Conditions</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-second">
  <section class="block">
    <h2>Newspaper</h2>
    <ul>
      <li><a href="https://allaccess.forumcomm.com/allaccess/parkrapidsenterprise" title="">Subscribe to the Paper</a></li>          </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript region region-postscript-third">
  <section class="block">
    <h2>Contact</h2>
    <ul>
      <li><a href="/contact-us" title="">Contact Us</a></li>
      <li><a href="http://forumcomm.desk.com/" title="">Get Website Help</a></li>
      <li><a href="http://www.jobshq.com/employers/page/profile/employer/34/" title="">Work With Us</a></li>
    </ul>
  </section>
</div><div class="grid-4 fcc-omega-postscript last-omega-col region region-postscript-fourth">
  <section class="block">
    <h2>More</h2>
    <ul>
      <li><a href="http://www.jobshq.com" target="_blank" title="JobsHQ">JobsHQ</a></li>
      <li><a href="http://www.carshq.com" target="_blank" title="CarsHQ">CarsHQ</a></li>
      <li><a href="http://www.homeshq.com" target="_blank" title="HomesHQ">HomesHQ</a></li>
      <li><a href="http://www.northlandoutdoors.com" target="_blank" title="Northland Outdoors">Northland Outdoors</a></li>
      <li><a href="http://www.agweek.com" target="_blank" title="Agweek">Agweek</a></li>
      <li><a href="http://impact.areavoices.com" target="_blank" title="Impact Magazine">Impact Magazine</a></li>
    </ul>
  </section>
</div><div class="grid-16 region region-postscript-fifth">
  <section class="block block-menu block-menu-footer-social-menu block-menu-menu-footer-social-menu odd" id="block-menu-menu-footer-social-menu">
    <h2>Social</h2>
    <ul>
      <li><a href="http://www.areavoices.com" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/areavoices-social.png" /> Areavoices</a></li>
      <li><a href="https://www.facebook.com/editorial.parkrapids" title="Find us on Facebook"><img alt="Find us on Facebook" src="/sites/all/themes/fcc_basetheme/images/icons/fb-social.png" /> Facebook</a></li>      <li><a href="/latest/rss/" title=""><img alt="" src="/sites/all/themes/fcc_basetheme/images/icons/rss-social.png" /> RSS Feeds</a></li>
    </ul>
  </section>
</div>  </div>
</div><div id="zone-footer-wrapper" class="zone-wrapper zone-footer-wrapper clearfix">  
  <div id="zone-footer" class="zone zone-footer clearfix container-16">
    <div class="grid-16 region region-footer" id="region-footer">
  <div class="region-inner region-footer-inner">
    <div class="block block-fcc-custom-blocks block-footer-site-info block-fcc-custom-blocks-footer-site-info odd block-without-title" id="block-fcc-custom-blocks-footer-site-info">
  <div class="block-inner clearfix">
                
    <div class="content clearfix">
      
<div class="vcard footer-contact">
  <div hidden="hidden">
    <div class="fn" style="display:none"> <a href="http://www.forumcomm.com/">Forum Communications Company</a></div>
    <span class="version" hidden="hidden" style="display:none">3.0</span>

    <div class="n listed-fields" style="display:none"> 
      <span class="given-name">&copy; Park Rapids Enterprise</span>
      <span class="family-name">Forum Communications Company</span>
    </div>

    <span class="email" style="display:none"> <a href="websitesupport@forumcomm.com">websitesupport@forumcomm.com</a></span>
    <div class="org">&copy; Park Rapids Enterprise</div> and
    <div class="role"><a href="http://www.forumcomm.com/">Forum Communications Company</a></div><br />

    <div class="adr listed-fields">
      <div class="street-address listed-fields">203 Henrietta Avenue North</div>
      <span class="locality">Park Rapids</span>, 
      <span class="region">Minnesota</span> 
      <span class="postal-code">56470</span>
    </div>

    Call us at <div class="tel">(218) 732-3364</div>
  </div>
</div>    </div>
  </div>
</div>  </div>
</div>  </div>
</div></footer>  </div><div class="region region-page-bottom" id="region-page-bottom">
  <div class="region-inner region-page-bottom-inner">
    <div><a rel="nofollow" href="http://www.fccnn.com/newspaper.php"></a></div>  </div>
</div><script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/tracker.js"></script>
<script type="text/javascript" defer="defer" src="http://tracking.fccinteractive.com/recommendationTracker.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery.ajax({url:'http://itracking.fccinteractive.com/tracking/drupalcms/insert_impressions.php?domain=parkrapidsenterprise.com&tags=opinion,park rapids lions, Lions Clubs International',type:'GET',dataType:'jsonp',crossDomain:true});
//--><!]]>
</script>
<script type="text/javascript" src="https://i.simpli.fi/dpx.js?cid=4004&amp;m=1"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/jsr_class.min.js?ook9l6"></script>
<script type="text/javascript" src="https://widgets.stagingjobshq.com/dist/loadJobsHQ.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/widgets-page.min.js?ook9l6"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_JozVjTMXs55bUfFMpJpqqcKwp4OKeoevi65GD95_4ys.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
jQuery(document).ready(function(){addthis.init()});
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_jNw4EtyrzIApV82kEWjNIwPts-FQ67yNMAmIDs7C-NE.js"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/widgets-html.min.js?ook9l6"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
if (jQuery(window).width() <= 728) {
    jQuery('#boxes-box-hq_widgets').remove();
    jQuery('div.spingo-widget').remove();
    }
//--><!]]>
</script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/all/themes/fcc_basetheme/js/min/clicktracking-global.min.js?ook9l6"></script>
<script type="text/javascript" src="http://www.parkrapidsenterprise.com/sites/default/files/js/js_s6x42LSxRLi0Ub3S3e7HL1kmAtzsVGIyuWWtC6hytII.js"></script>
<script type="text/javascript">
<!--//--><![CDATA[//><!--
// Quantcast Tag
        var ezt = ezt ||[];

        (function(){
          var elem = document.createElement('script');
          elem.src = (document.location.protocol == 'https:' ? 'https://secure' : 'http://pixel') + '.quantserve.com/aquant.js?a=p-f1gwFa5-x-0VY';
          elem.async = true;
          elem.type = 'text/javascript';
          var scpt = document.getElementsByTagName('script')[0];
          scpt.parentNode.insertBefore(elem,scpt);
        }());

        ezt.push({qacct: 'p-f1gwFa5-x-0VY',
            uid: '' });
      
//--><!]]>
</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>

    <!-- Quantcast -->
    <noscript>
      <img src="//pixel.quantserve.com/pixel/p-f1gwFa5-x-0VY.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/>
    </noscript>

    
        <div id='in-page-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('in-page-ad');
          });
        </script>
        </div>
        <div id='wallpaper-ad'>
        <script type='text/javascript'>
          googletag.cmd.push(function() {
            googletag.display('wallpaper-ad');
          });
        </script>
        </div>  </body>
</html>